No pixopoint themes will upload ( ‘Invalid Archive Structure’ )

Forums Forums Templates and themes No pixopoint themes will upload ( ‘Invalid Archive Structure’ )

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #910

    Hey guys,

    When ever I download a pixopoint theme and try to upload them to my wordpress account – it comes up this with this error message:

    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    It only happens with these themes (modified and default themes provided by the generator).

    I googled it and it says to replace the http.php file, I did, but it made no difference.

    Please help!

    Thank you in advance!


    I have no idea what you are doing wrong. The themes are not an archive, they’re just random PHP, image and CSS files so I don’t understand what that error means at all.


    Try updating you http.php in the wp-includes folder.
    Hopefully that helps.


    @BuLe – how does that help this problem?


    I have this same problem…


    I have no way of helping. That error message makes no sense to me whatsoever.

    WordPress themes do not contain archives so I can’t see how a theme could possibly trigger this error. Maybe I’m missing something obvious, but I don’t have the foggiest idea what that could be. If there is any more information you can provide that would be really useful as at the moment I can’t really do anything to help.



    Same problem here. I notice that the thumbnail file has 0 bytes, which means there is no thumbnail. Can’t that be the problem?


    If you can provide me with an XML file which demonstrates the problem then I’ll take a look and see if I can figure out what is going wrong for you.



    I just had the exact same problem.  I tried two different versions of the theme I’m working on and the same thing occurred each time.


    I just saw the attachment reference, so here is the xml file for the previous post.


    There does not appear to be anything wrong with the thumbnail.png file I downloaded, however the screenshot.png file is completely blank, no matter what value I put it into the form field. I’m not sure what the problem is there, but it can be fixed by simply replacing the existing screenshot.png with a new image after the export has been completed. I’ll get this fixed in a future version.


    I’m getting this same problem, but I realized that my problem is not an archive within the exported zip file — it’s the zip file itself!  I couldn’t upload the zip file to WordPress, and when I tried opening the exported zip file in Windows I got the message, "The compressed (zipped) Folder is invalid."


    I seem to have fixed it.  There were a number of places where I still had "Make a selection" so I either selected "none" (when "Make a selection" was the first item in a drop down list and "none" was at the bottom), or I specified the font (when "Make a selection" was next to a drop down font list).

    It might save some exporting confustion if these "Make a selection" choices were already defaulted.


    Sorry about the bugs, they’re annoying me more than anyone else. I’ll get them ironed out in the next release. In fact the next version won’t be able to have any of those bugs because of the way it works (it’s inherently less buggy because of the way it works). I’m still not sure when that will be ready for release though sorry.


    I have a different problem
    Parse error: syntax error, unexpected $end in C:xampplitehtdocswordpresswp-contentthemesrevolution_generatedfunctions.php on line 1052

    for every them tried


Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.